Help:Visuele tekstverwerker

Uit Cultureel Erfgoed Standaardentoolbox
(Doorverwezen vanaf Help:Visuele tekstverwerker)
Ga naar: navigatie, zoeken


De visuele tekstverwerker openen

Om een pagina met de visuele tekstverwerker te bewerken, klikt u op "Bewerken" bovenaan de pagina.

Het openen van de pagina om deze te bewerken kan enkele seconden duren, of langer wanneer de pagina erg groot is.

De klassieke wikitekst-bewerker kan geopend worden door te klikken op "Brontekst bewerken".

VisualEditor - NL - Edit tab.PNG

U kunt de visuele tekstverwerker ook openen door te klikken op "bewerken" bij een paginasectie.

Aan de slag: de werkbalk van de visuele tekstverwerker

De werkbalk van de visuele tekstverwerker verschijnt bovenaan uw scherm zodra u met deze tekstverwerker aan de slag gaat. De werkbalk bevat enkele bekende pictogrammen:

Ongedaan maken en Opnieuw uitvoeren van de wijzigingen die u hebt aangebracht.

De keuzelijst Koppen: Maakt het mogelijk het kopniveau te wijzigen. De standaardsectiekop is "Kopje". Het normale tekstformaat is "Paragraaf".

Opmaak: A opent een menu. Voor een onderdeel effect heeft, moet u eerst de betreffende tekst selecteren.
  • "Vet" (V) zet de geselecteerde tekst vetgedrukt.
  • "Cursief" (C) zet de geselecteerde tekst cursief.
  • "Superscript" (x2) zet de geselecteerde tekst in een kleiner lettertype en wat hoger dan de rest van de tekst.
  • "Subscript" (x2) zet de geselecteerde tekst in een kleiner lettertype en wat lager dan de rest van de tekst.
  • "Doorhalen" (S) creëert een volle lijn doorheen de geselecteerde tekst.
  • "Computercode" (twee accolades: {}) verandert het lettertype van de geselecteerde tekst naar een monospacefont, waardoor er een verschil wordt gecreëerd met de normale tekst.
  • "Onderstrepen" (U) onderstreept de geselecteerde tekst
  • "Taal" ("Aあ") wordt gebruikt om de taal (bijvoorbeeld "Nederlands") en de schrijfrichting (bijvoorbeeld links-naar-rechts) van de geselecteerde tekst te labelen.
  • "Opmaak wissen" (" ⃠ ") verwijdert alle opmaak in de geselecteerde tekst, inclusief links.

Linkhulpmiddel: de 'kettingschakel' is het linkhulpmiddel. Nadat u hierop klikt (en eerst tekst geselecteerd hebt) wordt een dialoogvenster geopend.

⧼visualeditor-toolbar-cite-label⧽ menu: Het menu "⧼visualeditor-toolbar-cite-label⧽" wordt gebruikt om voetnoten en referenties in de lopende tekst in te voegen. Op elk project bestaat de mogelijkheid om via dit menu een "⧼visualeditor-dialogbutton-reference-tooltip⧽" aan referenties toe te voegen en om citaten te "⧼visualeditor-dialog-reference-useexisting-tool⧽". Het menu bevat ook snelkoppelingen naar lokale referentiesjablonen, als deze geactiveerd zijn op uw wiki.

(Instructies voor het toevoegen van lokale referentiesjablonen aan het menu ⧼visualeditor-toolbar-cite-label⧽ zijn te vinden op mw:VisualEditor/Citation tool.)


Lijsten & inspringen: De eerste twee pictogrammen maken het mogelijk respectievelijk een "Ongenummerde lijst" of "Genummerde lijst" te maken. De laatste twee dienen om de inspringing te verkleinen of vergroten.

Invoegen: dit menu kan verschillen tussen de projecten. Hieronder staat een lijst van alle mogelijke opties die er kunnen verschijnen.
  • "Media" (een afbeelding van een berglandschap) opent het media-dialoogvenster.
  • "⧼visualeditor-mwgalleryinspector-title⧽" (een reeks foto's) creëert een galerij van foto's op de pagina.
  • "Sjabloon" (een puzzelstuk) wordt gebruikt om een sjabloon te bewerken
  • "Opmerking" (een tekstballon) wordt gebruikt om onzichtbare commentaren op de pagina in te voegen; deze zijn enkel zichtbaar in de bewerkingsmodus
  • "⧼visualeditor-dialogbutton-referenceslist-tooltip⧽" (drie boeken) opent een dialoogvenster waarin kan bepaald worden op welke plaats de bronvermelding komt te staan. Dit hoeft meestal maar een keer per pagina te worden gedaan.
  • "Speciaal teken" (Ω) wordt gebruikt om speciale tekens in te voegen (zie onder).

Invoegen van speciale tekens: de knop "Speciaal teken" in het menu "Invoegen" opent een dialoogvenster met verschillende speciale tekens. Door op een van de tekens te klikken wordt dat teken in de tekst ingevoegd. Deze lijst bevat standaardsymbolen, accenten en wiskundige symbolen. (Deze lijst kan lokaal worden aangepast. Zie mw:VisualEditor/Special characters voor meer informatie.)

Het menu Pagina-instellingen bevindt zich links van de knop Pagina opslaan. Dit menu bevat opties om pagina-instellingen (zoals een eventuele doorverwijzing of indexering) te veranderen; om categorieën toe te voegen, te bewerken of te verwijderen; en om, via "Taal", een lijst te krijgen van dezelfde artikels in andere talen. U kan hier ook omschakelen van de visuele tekstverwerker naar de klassieke wikitext (enkel in deze richting) zonder niet-opgeslagen wijzigingen te verliezen.

Wijzigingen opslaan

Wanneer u klaar bent met bewerken, klikt u op de groene knop "Pagina opslaan". (Zolang er geen wijzigingen zijn gedaan is de groene knop grijs en kan er niet worden opgeslagen.) Om alle wijzigingen te annuleren, kan u gewoon uw browservenster sluiten.

Als u op de groene knop "Pagina opslaan" klikt, wordt er een dialoogvenster geopend. Hierin kan u uw bewerking samenvatten, de bewerking markeren als kleine wijziging en aangeven de pagina in de toekomst te willen volgen. Het veld voor de samenvatting is het equivalent van het veld "Samenvatting:" in de normale wikitextbewerker.

U kunt ook uw wijzigingen controleren alvorens ze op te slaan, om er zeker van te zijn dat ze het gewenste resultaat geven. Dit kan met de knop "Wijzigingen controleren". Dit is het equivalent van de knop "Wijzigingen bekijken" in de normale wikitextbewerker. "Annuleren" brengt u terug naar de bewerkingspagina. U kan uw wijzigingen later opslaan.


Links bewerken

Links kunnen worden toegevoegd door te klikken op het "Koppeling"-pictogram (kettingschakels) op de werkbalk.

Als u tekst selecteert of de cursor op een woord plaatst, kunt u met "Koppeling" van die tekst een link maken.


Met de knop of sneltoets wordt een dialoogvenster geopend waarin u de link kunt typen.

De visuele tekstverwerker zal waar mogelijk helpen met interne links door suggesties te doen terwijl u typt.


Wanneer u een link hebt ingevoerd of geselecteerd kunt u op Enter drukken, buiten het dialoogvenster klikken of op het pictogram "Afgerond" (<) drukken. De link zal dan op de pagina van de visuele tekstverwerker verschijnen, maar pas opgeslagen worden wanneer u de pagina opslaat.

Linken naar een webpagina buiten Wikipedia gaat op dezelfde manier; vul de link in het tekstvak in en hij zal als "⧼visualeditor-linkinspector-suggest-external-link⧽" worden toegevoegd.

Externe links zonder labels zien er als volgt uit: [1] Deze kunnen worden toegevoegd door uw cursor buiten een woord te plaatsen (bijvoorbeeld na een spatie). Open het linkhulpmiddel door op de knop te klikken of een snelkoppeling te gebruiken. Type de URL in het veld en klik op "Afgerond" om de link in te voegen.

Om een bestaande link te bewerken of te verwijderen, klikt u eerst op de link in de tekst en daarna op het "Koppeling"-pictogram er vlakbij. Er verschijnt dan een dialoogvenster.

U kunt vervolgens de doellocatie van de link aanpassen. U kunt ook de link geheel verwijderen door te klikken op het pictogram "Verwijderen" (prullenbak) in de linkerbenedenhoek van het dialoogvenster. U kunt ook de doelpagina van de link in een apart venster openen door op "⧼visualeditor-linkinspector-open⧽" te klikken. (Dit komt van pas om te kijken of een link effectief werkt.)

Referenties bewerken

Een bestaande referentie bewerken


Om een bestaande referentie te bewerken, klikt u op de referentie in de tekst (vaak een getal tussen accolades). Vervolgens ziet u ofwel een "⧼visualeditor-dialogbutton-reference-tooltip⧽"-pictogram (bladwijzer) of het icoon en de naam van het sjabloon dat gebruikt werd om deze referentie te in te voegen. Door op dit pictogram te klikken kan u de referentie bewerken.

Als u op het "⧼visualeditor-dialogbutton-reference-tooltip⧽"-pictogram klikt, verschijnt er een dialoogvenster waarin u de inhoud van de referentie kunt bewerken.

Veel wiki's gebruiken sjablonen om referenties volgens een bepaalde standaard op te maken. Indien een sjabloon werd gebruikt bij een bepaalde referentie, zal de hele tekst in het sjabloon worden gemarkeerd als u de informatie van de referentie bekijkt.

Indien er een sjabloon werd gebruikt en u de referentie-informatie bekijkt binnen dat sjabloon, zal het Sjabloon-pictogram (puzzelstuk) verschijnen. Klik hierop om de inhoud van de referentie in het minibewerker te bewerken.


Als er, in plaats van het "⧼visualeditor-dialogbutton-reference-tooltip⧽"-pictogram (bladwijzer), een pictogram voor een standaard citaatsjabloon wordt getoond, kan u rechtstreeks naar de minibewerker gaan door op dat pictogram te klikken.

In de minibewerker kan u nieuwe soorten informatie toevoegen en verwijderen of de bestaande inhoud veranderen. Enkel velden (sjabloonparameters) die inhoud bevatten zouden getoond mogen worden in het begin. Om bijkomstige velden in te voegen, klikt u op "Meer informatie toevoegen" onderaan de bewerker.

Klik op "Wijzigingen toepassen" als u klaar bent.

Een bestaande referentie hergebruiken


Als de pagina al een geschikte referentie bevat kan u deze hergebruiken.

Om een bestaande referentie te hergebruiken plaatst u de cursor daar waar u de referentie in de tekst wilt invoegen, en klikt u op het "⧼visualeditor-dialog-reference-useexisting-tool⧽"-pictogram (bladwijzer) uit het menu "⧼visualeditor-toolbar-cite-label⧽".


In het dialoogvenster ⧼visualeditor-dialog-reference-title⧽ kan u de betreffende referentie opzoeken en selecteren. Indien er gebruik wordt gemaakt van veel referenties, kan u het zoekvak ("⧼visualeditor-reference-input-placeholder⧽") gebruiken om alleen die referenties weer te geven die met een bepaalde tekst overeenkomen.

Een nieuwe referentie toevoegen


Om een nieuwe referentie toe te voegen via het menu "⧼visualeditor-toolbar-cite-label⧽", plaatst u de cursor daar waar u de referentie in de tekst wilt invoegen, en klikt u op het betreffende pictogram in het menu.

Een "basis"-referentie gebruiken


Deze afbeelding geeft weer hoe de "⧼visualeditor-dialogbutton-reference-tooltip⧽"-functie eruit ziet. In de referentiebewerker kan u uw referentie, inclusief opmaak, toevoegen.

U kunt de referentie indelen in een bepaalde groep, hoewel dit veld vaak blanco wordt gelaten. (Deze optie wordt gebruikt om groepen referenties te tonen met de "⧼visualeditor-dialogbutton-referenceslist-tooltip⧽"-tool.)


Als u een nieuwe referentie toevoegt en daarbij een sjabloon wilt gebruiken, klikt u op het "Sjabloon"-pictogram (puzzelstukje) in het menu "Invoegen" van de referentiebewerker.

Zoek vervolgens het sjabloon dat u wilt gebruiken, voeg het toe en bewerk het zoals een normaal sjabloon. (Zie de sectie over het bewerken van sjablonen hieronder voor meer informatie over sjablonen.)

Klik op "Wijzigingen toepassen" om terug te keren naar de referentiebewerker en nogmaals op "Wijzigingen toepassen" om terug te keren naar de pagina die u aan het bewerken bent.


Wanneer de pagina nog geen referentielijst bevat (bijvoorbeeld wanneer u de eerste referentie aan het toevoegen bent), moet u deze lijst eerst toevoegen om uw referentie te kunnen weergeven.

Plaats de cursor op de plaats waar u wilt dat de referenties komen te staan (meestal onderaan de pagina), open het menu "Invoegen" en klik op "⧼visualeditor-dialogbutton-referenceslist-tooltip⧽" (drie boeken) om de lijst toe te voegen.


Wanneer u verschillende groepen referenties heeft gemaakt (hetgeen niet zo vaak voorkomt) kunt u in dit dialoogvenster de groep specifiëren. Enkel die referenties die ertoe behoren worden dan weergegeven.

De laatste stap is klikken op "Invoegen".

Afbeeldingen en andere mediabestanden bewerken

Afbeeldingen bewerken

Om een nieuwe afbeelding (of een ander mediabestand) aan de pagina toe te voegen, klikt u op het "Media"-pictogram (een afbeelding van een berglandschap) in het menu "Invoegen". De foto zal worden toegevoegd op de plaats waar uw cursor zich op dat moment bevindt.

Door te klikken op het "Media"-pictogram opent u een dialoogvenster dat automatisch Wikimedia Commons en uw lokale wiki doorzoekt om bestanden te vinden die overeenkomsten vertonen met de pagina die u aan het bewerken bent.

U kunt andere mediabestanden zoeken door de tekst in het zoekvak van het dialoogvenster aan te passen.

Klik op een miniatuur om een bestand te kiezen. Hiermee plaatst u de afbeelding op de pagina die u aan het bewerken bent.


Nadat de door u gekozen afbeelding toegevoegd is aan de pagina zal er een ander dialoogvenster openen. Hier kan u een onderschrift aan de afbeelding toevoegen of het bestaande onderschrift aanpassen. Het onderschrift mag opmaak en links bevatten.

Het mediadialoogvenster kan ook worden gebruikt om een alternatieve tekst aan te bieden voor gebruikers die een screenreader gebruiken of die afbeeldingen hebben uitgeschakeld.

U kan verschillende afbeeldingsparameters gebruiken in het venster "Geavanceerde instellingen". Het gaat hier onder andere om de uitlijning, het type afbeelding en de grootte.

Wanneer u klaar bent, klikt u op "Wijzigingen toepassen" om het dialoogvenster te sluiten en terug te keren naar de tekstverwerker.

U kan het onderschrift van een bestaande afbeelding toevoegen of aanpassen door te klikken op de afbeelding en vervolgens op "Media" te klikken.

U kan de grootte van een bestaande afbeelding aanpassen door op de afbeelding te klikken en vervolgens met de bijbehorende knop (de tweezijdige pijl linksbeneden) de afbeelding aan te passen.

U kan ook een afbeelding verplaatsen (hoger of lager op de pagina) door deze te verslepen.


Mediagalerijen bewerken


Om een bestaande galerij in de visuele tekstverwerker te bewerken, klikt u op die galerij. Daarna vindt u onderaan de galerij het galerij-icoon (een reeks foto's). Hiermee opent u de galerijbewerker met een lijst van alle afbeeldingen die reeds in de galerij te vinden zijn.
De galerijbewerker is een simpel venster waarmee u bestaande galerijen kan aanpassen met wikitekstopmaak. Om een nieuwe afbeelding aan een bestaande galerij toe te voegen typt u de naam van de afbeelding, gevolgd door een pipe (|) en het onderschrift voor de afbeelding. Er staat één afbeelding per regel. U kan deze lijst ook bewerken om afbeeldingen te herschikken, te verwijderen of om onderschriften te bewerken.

Wanneer u op "Afgerond" klikt wordt de galerijbewerker gesloten. De veranderingen zouden meteen zichtbaar moeten zijn zoals hij eruit zal zien nadat de wijzigingen zijn opgeslagen.

Let erop dat - door de galerijbewerker te sluiten - uw wijzigingen nog niet worden opgeslagen. Net zoals met andere bewerkingen in de visuele tekstverwerker worden uw wijzigingen pas doorgevoerd nadat de hele pagina opgeslagen wordt.

Sjablonen bewerken

Om een nieuw sjabloon aan de pagina toe te voegen, plaatst u de cursor daar waar u het sjabloon wilt invoegen, en klikt u op het "Sjabloon"-pictogram (puzzelstukje) in het menu "Invoegen".

Vul de naam in van het sjabloon dat u wilt invoegen. Wanneer het sjabloon in de lijst verschijnt klikt u erop. Klik daarna op "Sjabloon toevoegen".

Het is mogelijk reeds ingevoegde sjablonen te bewerken door erop te klikken (ze worden dan blauw) en vervolgens te klikken op het verschijnende "Sjabloon"-pictogram (puzzelstukje).

Bij het toevoegen of bewerken van een sjabloon verschijnt het "Transclusie"-venster. Wanneer het sjabloon al werd geüpdatet om TemplateData te bevatten, zal dit venster een lijst individuele parameters tonen. In het andere geval verschijnt er een link naar de documentatie.

Wanneer u een reeds bestaand en geüpdatet sjabloon bewerkt zullen er in het venster parameterwaarden verschijnen.


Bij een bestaand sjabloon kunt u de reeds bestaande parameters bewerken of bijkomstige parameters toevoegen door op "Meer informatie toevoegen", onderaan het venster, te klikken.

Wanneer een sjabloon andere sjablonen bevat, worden deze ingebedde sjablonen als parameter weergegeven. Op deze manier kunnen ze worden bewerkt of verwijderd.

Nieuwe ingebedde sjablonen worden op dezelfde manier toegevoegd als parameters. Mogelijk moet u in de sjabloondocumentatie nagaan of het ingebedde sjabloon wordt ondersteund.


Wanneer u klaar bent, klikt u op "Wijzigingen toepassen" om het dialoogvenster te sluiten en terug te keren naar de tekstverwerker.

Sjablonen substitueren


Wanneer een sjabloon gesubstitueerd moet worden, typt u subst: (inclusief dubbelepunt) voor de naam van het sjabloon.

"Automatisch aanvullen" werkt niet met subst:; als u deze functie nodig heeft, voegt u subst: pas toe nadat u het gezochte sjabloon heeft gevonden.

Klik daarna op de groene knop "Sjabloon toevoegen".


Voeg op de normale wijze parameters toe en klik op "Wijzigingen toepassen".

Nadat u op "Wijzigingen toepassen" heeft geklikt wordt het sjabloon zichtbaar op de pagina. Wanneer u klaar bent kunt u de gehele pagina opslaan.


Categorieën bewerken

Om categorieën te bewerken klikt u op "Categorieën" in het menu "Pagina-instellingen".

De knop "Categorieën" opent een dialoogvenster dat de huidige categorieën weergeeft en het mogelijk maakt nieuwe toe te voegen.

Het is mogelijk om de naam in te stellen waarop de pagina in categorieën moet worden gesorteerd.

Een voorbeeld: de standaardnaam voor het artikel "George Washington" is "Washington, George", waardoor het artikel in de categorie "Presidenten van de Verenigde Staten van Amerika" onder de letter "W" wordt gesorteerd (en niet onder "G").


Om een nieuwe categorie toe te voegen, vult u in het tekstvak "Categorie toevoegen" de naam in. Terwijl u typt zal de visuele tekstverwerker mogelijke overeenkomsten zoeken in bestaande categorieën. U kan een bestaande categorie kiezen of u kan een nieuwe, onbestaande categorie toevoegen. (Tot deze nieuwe categoriepagina is aangemaakt zal de nieuwe categorie in de wijzigingen voorkomen als een rode link.)

Om een bestaande categorie te verwijderen, klikt u erop en daarna op het pictogram "Verwijderen" (prullenbak) in het dialoogvenster dat verschijnt.

U kunt daar ook de sorteernaam voor die specifieke categorie opgeven (hetgeen vrij zeldzaam is). Hierdoor wordt de normale sorteervolgorde genegeerd.


Wanneer u klaar bent met categorieën bewerken, klikt u op "Wijzigingen toepassen" om terug te keren naar de tekstverwerker.


Pagina-instellingen bewerken

Om de instellingen van een pagina te bewerken klikt u in het menu "Pagina-instellingen" op het pictogram "Pagina-instellingen".

Het pictogram "Pagina-instellingen" opent een dialoogvenster met verschillende opties.

U kan gemakkelijk een pagina als doorverwijzing instellen door "Pagina doorsturen naar" aan te vinken en vervolgens de pagina waarnaar u de lezer wilt verwijzen in te typen.

Onderaan het venster is er de mogelijkheid om ervoor te zorgen dat paginahernoemingen niet automatisch deze doorverwijzing updaten. Deze functie wordt zeer zelden gebruikt.


Het wel of niet tonen van de inhoudstafel op een pagina kan worden aangeduid met een van deze drie knoppen. De standaardwaarde is "Als nodig", waarmee een inhoudstafel wordt getoond van zodra er drie of meer koppen in het artikel staan.

Door dit kadertje aan te vinken zorgt u ervoor dat er geen "bewerk"-knop verschijnt naast elke kop.

Klik op "Wijzigingen toepassen" waneer u klaar bent met de Pagina-instellingen te bewerken om terug te keren naar de tekstverwerker.


Wiskundeformules bewerken

Om een nieuwe wiskundige formule in te voegen, plaatst u uw cursor op de plaats waar u deze wilt toevoegen en klikt u op het "⧼math-visualeditor-mwmathinspector-title⧽"-pictogram("Σ") in het menu "Invoegen".

Hierna wordt er een venster geopend waarin u de formule kan ingeven met behulp van de LaTeX-syntax. De visuele tekstverwerker zal de formule tijdens het typen updaten, zodat u uw wijzigingen meteen kan zien. Wanneer u klaar bent, klikt u op "Afgerond".

Om een bestaande wiskundige formule aan te passen klikt u op deze formule en klikt u op het "Σ"-pictogram dat verschijnt. Hierna wordt het dialoogvenster voor formules geopend, waar u uw wijzigingen kan doorvoeren.

15px Deze tekst is geheel of gedeeltelijk overgenomen van de Nederlandstalige Wikipedia en valt onder CC-BY-SA. Zie Wikipedia:Visuele tekstverwerker/Gebruikershandleiding voor een overzicht van de belangrijkste auteurs.